Cайт веб-разработчика, программиста Ruby on Rails ESV Corp. Екатеринбург, Москва, Санкт-Петербург, Первоуральск

Админка на Ruby on Rails

Проблемы с установкой gem nokogiri с RubyInstaller 2.4.1

Сейчас RubyInstaller для Windows распостраняется по новому адресу:

https://github.com/oneclick/rubyinstaller2/releases

Но после установки возникают проблемы с установкой gem-ов, например, Ruby on Rails последних версий, "спотыкаясь" на gem nokogiri.

  1. В каталоге установки Ruby запускаем ridk install, выбираем 3 пункт.
  2. ridk exec pacman -S mingw-w64-x86_64-libxslt
  3. gem install nokogiri --platform ruby -- --use-system-libraries

Далее gem Ruby on Rails устанавливается без проблем.

Для явного указания только платформы Ruby:

  1. gem install bundler
  2. bundler config force_ruby_platform true